Microsoft publie Entity Framework Core 5.0 RC 1


 

L’équipe Entity Framework Core a annoncé la première version candidate (RC1) du framework. Cette version inclut de nouvelles fonctionnalités telles que les relations plusieurs à plusieurs, les compteurs d’événements, la possibilité d’écouter les événements de sauvegarde, etc.

Les versions candidates d’EF Core 5.0 nécessitent .NET Standard 2.1. Cela signifie qu’EF Core 5.0 s’exécutera sur .NET Core 3.1 et ne nécessite pas .NET 5. Par contre, EF Core 5.0 ne fonctionnera pas sur les plates-formes .NET Standard 2.0, y compris .NET Framework. EF Core est distribué exclusivement sous la forme d’un ensemble de packages NuGet. Pour l’installer :

dotnet tool install –global dotnet-ef